Access Tutorial 6: Form Fundamentals

6.1 Introduction: Using forms as
the core of an application

Forms provide a user-oriented interface to the data
in a database application. They allow you, as a
developer, to specify in detail the appearance and
behavior of the data on screen and to exert a certain
amount of control over the user’s additions and mod-
ifications to the data.

Like queries, forms do not contain any data. Instead,
they provide a “window” through which tables and
gueries can be viewed. The relationship between
tables, queries, and forms is shown in Figure 6.1.

In this tutorial, we are going to explore the basic ele-
ments of form creation using Access’ form design
tools. In subsequent tutorials, we will extend the
functionality and ease-of-use of our basic forms with
subforms (Tutorial 7), “combo box” controls

(Tutorial 8), and triggers (Tutorial 13).
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FIGURE 6.1: The relationship between forms,
gueries, and tables.
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6.2 Learning objectives

O Do forms contain data?

O How do | create a form?
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6. Form Fundamentals

O How do | make the contents of a field on a
form read-only?

O What is an unbound text box? How do | create
one?

O How do | create a form using the form wizard?

O What is the difference between a columnar
(single-column) and tabular form?

6.3 Tutorial exercises

6.3.1 Creating a form from scratch

Although Access provides an excellent wizard for
creating simple forms, you will start by building a
form from scratch. This will give you a better appreci-
ation of what it is the wizard does and provide you
with the basic knowledge needed to customize and
refine the wizard’s output.

Tutorial exercises

» Create a new blank form based on the Courses
table, as shown in Figure 6.2.

» The basic elements of the design screen are
shown in Figure 6.3. Use the View menu to dis-
play the toolbox and field list if they are not
already visible.

6.3.1.1 Adding bound text boxes
» Add a “bound” text box for the DeptCode field by
dragging DeptCode from the field list to the form
background, as shown in Figure 6.4.
* Reposition the DeptCode text box in the upper
left of the form.

@

Remember that you can always use the
“undo” feature to reverse mistakes. Select
Edit > Undo from the menu or simply press
Control-Z (this works the same in virtually all
Windows applications).

20f15

M Home | [4Previous | [ Next P |




6. Form Fundamentals

Tutorial exercises

FIGURE 6.2: Create a new form to display data fromthe = Courses table.

g2 univl_v7 : Database

=13

Tablesl Oueries Forms | B Repunsl z Macrusl g Modulesl

| Hew Form
a2 Select thd=orms tab from
the database window.

rm without using

‘b SelectDesign View (do not
use the wizard at this point)

P - I

Faorm Wizard
AutaForm: Colurmnar
AutoForm: Tabular
AutoForm: Datasheet
ChartWWizard
PivotTable Wizard

Bind the form to the
C Courses table.

Choose the takle or guery where

[

the object's data comes from:

(0] 9

@ Since you can build a formontop ofatableora |
query, both are shown in this list (here is wherea— %
meaningful naming convention starts to pay off)

Catalog View

Departments
Employees
gryCatalogMum
gryCourselengths
gryCourses
Sections
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6. Form Fundamentals Tutorial exercises

FIGURE 6.3: The basic elements of the form design screen.

B Form1 : Form @, Microsoft Access
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_The field list — shows the .fields The toolbox — the icons in the _ @ If the fielq list and toolbox
in the table or query to which the toolbox are used to create graphical are not displayed, use the
form is bound. items and controls on the form. View menu or toolbar icons.
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6. Form Fundamentals

@

Tutorial exercises

FIGURE 6.4: Create a bound text box for the DeptCode field.

Access uses the field’s caption property as the default label for the text box.
If no caption is specified, the field name (eR@eptCode ) is used. To save
time editing labels, choose your captions with this feature in mind.

B Form1 : Form

Ty Dragthe highlighted field on

e to the form’s detail section.
’_I XDetaiI e
To move an object and its | .
label, drag the center of the epariment coe: eptCode To H
object (the cursor becomes - N
a white arrow). To move // Alabl
just the object or just the [ 2
label, drag the upper left G
handle (the cursor becomes I
a pointing finger). e =
2 Select theDeptCode ' -
4 field in the field list. '
- N[=
5
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6. Form Fundamentals

» Drag the remaining fields on to the form, as
shown in Figure 6.5 (do not worry about whether
the fields are lined up perfectly).

» Select View > Form to see the resulting form.
Alternatively, press the form view icon ([E|).

» Select View > Form Design or press the design
view icon (&) to return to design mode.

6.3.1.2 Using a field’s properties to protect its

contents

Every object on an Access form (e.g., text box, label,
detail section, etc.) has a set of properties that can
be modified. In this section, you are going to use the
Locked and Enabled properties to control the user’s
ability to change the information in a field.
» Select the DeptCode text box and right-click to
bring up its property sheet, as shown in
Figure 6.6.

Tutorial exercises

 Scroll down the property sheet to the Locked
property and set it to Yes, as shown in
Figure 6.7.

» Switch to the form view and attempt to change
the contents of the DeptCode field.

A stronger form of protection than locking a field is
“disabling” it.

* Return to design mode and make the following
changes: reset the Locked property to No; set the
Enabled property to No.

» Attempt to change the contents of the DeptCode
field in form view, as shown in Figure 6.8.

» Save the form as frmCourses

6.3.1.3

All the text boxes created in the previous section
were “bound” text boxes—that is, they were bound to
a field in the underlying table or query. When you
change the value in a bound text box, you are mak-

Adding an unbound text box
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M Home | [4Previous | [ Next P |




6. Form Fundamentals

A

@

Tutorial exercises

FIGURE 6.5: Add the text boxes and switch to form view to see the resulting form.

Add the remaining
fields to the form.

Ifl

Text boxes are simply

I:“-l-]'l'g- ozt v DrR brg b g o brgrbrg gl ‘.‘WindOWS”On.tOtheﬁe|dS
“ Do in the underlying table.

_ |Depa‘cmentu: de:| |DeptC%Dde : =] urm1 Form I |

1 i““uu. Bttt .:i ICrsNulm | | | Department code: ICOMM

- [Title Course number: [250

Z Credite: |Creditls | I Title: [Introduction to Quantati.

; M i 5::tivitly I Credits: | 3

_ Ativity: [LEC

SelectView > Form from the

main menu to view the form.

You can add more than one field to the form with chk 1> [ v of 11
drag-and-drop operation by holding down @untrol
button when selecting the fields from the field list.
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6. Form Fundamentals

FIGURE 6.6: Bring up the property sheet for the

B Form1 : Form

Tutorial exercises

DeptCode text box.

Right-click once on the selected
object to get the pop-up menu.
B LR

I:"'|'1'|'2'|'3'|'4'|'5'|'5'|'?'|'3'|))/i

[ |[*Detai :

- ——=— = SelectProperties to get the

- epaftment cpde: | eptCI:Dde. | i A Ic pr0pelrty sheet.

1 [oausp a2 Crem Build Event.. gl Text Box: DeptCode___________E

- ITiﬂE Eantra] ijeard. FDrmat' Data | Ewent | Other Al |

2 \Foreme Cradits Dhjest o= MName.............. DeptCode -

_ [redte] I Caontrol Source . .. .. DeptCode
A it IACtivily Change To ' Format. .. ........ .. ;l

3 | | Align v | Decimal Places.... Auto

= Input Mask .. ... .. >LLLL
Select the object (e.g., the = Defaultvalie. ... :

F= | | % Copy \alidation Rule . /. @ The properties are broken down

De.ptCOde t.eXt bOX) or Faste Yalidation Text /... INto fOU_I’ groups. To see all the
which you wish to see the "o Status Bar Tex!. .. properties, select thall tab.

properties. When an object
has been selected, it is

Enter Key Befiaviar. De.c.
Allow AutoZorrect .. Yes

~

bordered by six dark
“handles”.

Some properties of the text box (such as
input mask) are inherited from the field
to which the text box is bound.
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6. Form Fundamentals

FIGURE 6.7: Change the Locked property of
DeptCode to Yes.

|:||'|'1-|-2'|'3'|'4-|-5'|'5-|-?-
[ |[*Detai
) ‘%epatmentc de:| @eptCDde :
- I = [
_] nnrsb anmbde | Irreblirn
:
- E FDrmatl Data | Ewent | Other All |
2 Enter Key Behawiar . Default =]
- [ Allow AutoCorrect . Yes
1 = YWisikble .. Yes
Display When .. .. .. Alwans
N Enahled ... ... . .
4 Locked .. .. . ...
- Fitteookup ... ..
- Auto Tab ... ..
5 Tab Stop . ... ..
‘_l Tab Index ...\ ..
Srrnll Rars "I

a2 Use the scroll bar to find
theLocked property.

Tutorial exercises

ing the change directly to the data in the underlying
table.

It is possible, however, to create objects on forms
that are not bound to anything. Although you will not
use many “unbound” text boxes in the assignment, it
IS instructive to see how they work.
» Create a new empty form bound to the Courses
table and save it using the name
frmCoursesUB .
« Select the text box tool (abl]) from the toolbox and
create and unbound text box, as shown in
Figure 6.9.

6.3.1.4 Binding an unbound text box to a field

The only difference between a bound and an
unbound text box is that the Control Source property
of a bound text box is set to the name of a field. In
this section, you are going to change the unbound
text box shown in Figure 6.9 to a bound text box.
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6. Form Fundamentals Tutorial exercises

FIGURE 6.8: Set the Enabled property of DeptCode to No and attempt to change the value in the
field.

SetLocked toNo and
A

Enabled to No.

I:"-l-1-|-2-|-3-|-4-|-5-|-5-|-?
[ ][ Detail
EJeptCIDde.

- }epahmentc (e|=x
Irramlurm

-] _E‘.mqul:l nirmhde |

B Text Box: DeptCode

Fc:rmatl Data, | Ewent | Other
Enter Keyw Behawvior. Default
- [ Allow AutoCarrect .. Yes

| = Misible .. ... L Yes

Switch to form view
to see the result.

A =

@ When a form object is disabled, it
cannot receive the “focus” (that is,
you cannot put the cursor on it).

Display When . ... .. RV
- Sialled Mo Depafiment cede: ICOMM
4 Laiclize] oo MNa Course number: [230 @ By default, disabled form objects are
- Filter Lookup ... Databas — [Froducion to Guemain greyed out. To override this feature,
. ?;tg;‘zz ----------- f‘(‘;‘g ; set theLocked property toYes and
- b e : Credits: | 3 theEnabled property toNo.
LI— Srenll Rars Mnre Aty ILEC
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6. Form Fundamentals Tutorial exercises

* Bring up the property sheet for the unbound text
box. Change its Control Source property from null
to DeptCode , as shown in Figure 6.10.

FIGURE 6.9: Create an unbound text box.

a2 Select the text box tool from the toolbox.
The cursor becomes a small text box.

6.3.2 Creating a single-column form
B frmCoursesUB : Form : USing the Wizard

L L L | | | |
%l : - L : : ° [ Now that you understand the basics of creating and

- ¢ Derel I I I modifying bound text boxes, you can rely on the form
- || [Texte]  funbound : wizard to create the basic layout of all your forms.
l_ /‘ A a:| * Create a new form bound to the Courses table
. ™l 2 using the form wizard, as shown in Figure 6.11.
- & |~ * Use the form wizard to specify the fields you want
3 b Click anywhere on the on your fo.rm qnd the order in wrll‘ich they a:ppear,
- detail section to create a = & as shown in Figure 6.12. Select “columnar” when
4 new unbound text box. prompted for the form type.

i ]

“Columnar” forms are called “single column”
forms in version 2.0.
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6. Form Fundamentals

FIGURE 6.

10: Set the Control Source property
of an unbound text box.

B frmCoursesUB : Form

D|-|-1'|'2-|--|-4'|'5-|-5'|'r'|'

[ |[*Deti

i | [ - [ .

- MJ EJeptCDde I

. = u

: | | |

- &5 Text Box: Text?
FDrmatl Data | Eventl Other All |

2 Mame ... .. Text -

- Caontrol Source . . . .. C

3 Format. .. ... ... .. |EE]aes]s]=

- Decimal Places ... [CrsMum

- Input kask . ... Title

4 Defaultalue . ... .. Credits

- validation Fule ... Activity

-5 Walidation Text ... ..

Status Bar Test ..
Use the pull-down list to set
the Control Source property
to DeptCode .

Tutorial exercises

FIGURE 6.11: Create a new form using the form
wizard.

New Form HE

Design View

toForm: Takbular

A . AutoForm: Datashest
This wizard automatically Chart Wizard

creates your form, based on the PivotTakle Wizard
fields ywou select.

o \ ?JtDFDI’mI Colurmnar
u

Select the formZ
A wizard.

Choose the table or query where -
the ohject's data comes from: ICDurses J

L
‘b Bind the form to the

Courses table.
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FIGURE 6.12: Use the form wizard to determine the order of fields on your form.

Form Wizard
Which fields do you want on your form?
?5 G “r'ou can choose from mare than one takle or queny.
Tables/Queries: @ The order in which
[Table: Courses =] the fields appear in
Availoblo Fislde. Seloctod Fiolde this pane is the order
Awailable Fields: Selected Fislds: in which they will
Title DeptCode

appear on the form.
Use the< and<<

Credits J

> | buttons to move
fields back to the
@ to show a field, either double- =N pane on the left.
click it or press the button. <<
1

To show all the fields, press the
>> putton.

S

Cancel ‘ | Mext > | Finish |
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6. Form Fundamentals

The primary advantage of the wizard is that it auto-
matically creates, formats, and aligns the bound text
boxes. Of course, once the wizard has created a
form, you are free to modify it in any way.

If you make a mistake when creating a form
(e.g., you put the fields in the wrong order) it
is often easier to use the wizard and start over
than to fix the problem manually.

6.4 Discussion

6.4.1 Columnar versus tabular versus
datasheet forms

Columnar forms show one record per page. Tabular
forms, in contrast, show many records per page and
are used primarily as subforms. There is also a a
datasheet form type, but it is seldom used since it
gives the developer relatively little control over the

Discussion

look and behavior of the data. The three different

types of forms are shown in Figure 6.13.

6.5 Application to the assignment
» Use the wizard to create columnar forms for all
your master tables. Note that in some cases
(e.g., BackOrders ) you will want to base the
form on a join query rather than table in order to
show important information such as CustName
and ProductName .
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6. Form Fundamentals Application to the assignment

FIGURE 6.13: The same information displayed as a columnar, tabular, and datasheet form.

@Courses M=l A ol torm displ
" | Departmentcode [COMM| - = on%orlé?onrgrpg:rgaglzp.) Ve
Course number W ”
Tile | 5 Courses (tabular) =] B3
Department coc Course numkbe Title Credits Activit,
Credits I_ b | |COkARA 280 Introduction to Quantatrve Decision Making J|LEC
Activity Iﬁ COkM 29 Applied Statistics in Business 4/|LEC
COkM 3 Financial Accounting JLEC
Record: 14/ < || 1k COMM 439 B Courses (datasheet) O] =]
CRWR 202 Title Activity
CRWR 496 | |COMI290 Introduction to Quantative Decisio 3 LEC
A tabular form EDUC WE | |comr291  Applied Statistics in Business 4 LEC
displays more thamr——#={="= | |comrsst Financial Accounting 3 LEC
one record per page. VAT 07 | |COME438 Advanced Topics in Information S 3 LEC
MUSE 105 | |CRW 202 | Creative Forms 5 SEM
* | |CRW 496 Poetry Tutorial g TUT
.. . S EDUC 306 | Curriculum and Instruction in Hea 3 LEC
ngtgfgighrgrm asugjr?/f't'sﬁﬁgoittg?vgit?ﬁgee}“ [ |ENGL 301 Technical and Business Writing 3 LEC
designer very little control over the format of thé 'P;'Ag E E;L‘jlgzolt\'ﬂoa’;ﬂti E:;T:;‘gt'c Proces z ::EE o
ta, it i nerally in ropriate for inan || h
(ejﬁda:’use? ggpﬁcgtﬁcl)napp opriafe for tise i Recaord: 14] 4 ||—9 b |1 p] of 11 <] | ol
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