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n Pro grammin g 

 entry is complete, the inventory update 
s executed, and so on.

iven programming, graphical user interfaces 
nd object-orientation are all related since 
e those created in Tutorial 6) and the 
l interface objects on the forms serve as the 
for the entire application. To create an 
ven application, the programmer creates 
grams and attaches them to events associ-
 objects, as shown in Figure 13.1. In this 
behavior of the application is determined by 
ction of a number of small manageable pro-
ther than one large program.
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Access Tutorial 13: Event-Drive
Usin g Macros

troduction: What is event-
iven programming?

ntional programming, the sequence of oper-
r an application is determined by a central 
g program (e.g., a main procedure). In 
ven  programming, the sequence of opera-
an application is determined by the user’s 
n with the application’s interface (forms, 
uttons, etc.). 

ple, rather than having a main procedure 
utes an order entry module followed by a 
fication module followed by an inventory 
odule, an event-driven application remains 

ckground until certain events happen: when 
 a field is modified, a small data verification 
is executed; when the user indicates that 

the order
module i

Event-dr
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Triggers
ents on forms “trigger” actions, event/proce-
binations are sometimes called triggers .

ple, the action query you attached to a but-
ction 11.3.5 is an example of a simple, one-
gger. However, since an action query can 
orm one type of action, and since you typi-
e a number of actions that need to be per-

acros or Visual Basic procedures are 
used to implement a triggers in Access.

he Access macro language
iscovered in Tutorial 12, writing simple VBA 
 is not difficult, but it is tedious and error-
rthermore, as you will see in Tutorial 14, 
ramming becomes much more difficult 
 have to refer to objects using the naming 
ns of the database object hierarchy. As a 

ence, even experienced Access program-
In. Event-Driven Programming Using Macros

13.1.1
Since ev
dure com

For exam
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13.1.2 T
As you d
programs
prone. Fu
VBA prog
when you
conventio
consequ

properties

events

interface object
cmdUpdateCredits

Caption
Enabled
...

On Click
On Got Focus
...

procedure

FIGURE 13.1: In a trigger, a procedure is 
attached to an event.

An object, such as the 
button created in 
Section 11.3.5, has 
predefined properties and 
events. For a button, the 
most important event is 
On Click.

A procedure (such as an 
action query, macro, or VBA 
function or subroutine) can be 
attached to an event. When 
the event occurs, the 
procedure is executed.
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e procedure to the correct event of the cor-
ct.

lecting the correct object and the correct 
ent for a trigger is often the most difficult 
rt of creating an event-driven application. It 
best to think about this carefully before you 
t too caught up in implementing the proce-
re.

arning objectives
hat is event-driven programming? What is a 
gger?

w do I design a trigger?

w does the macro editor in Access work?

w do I attach a macro to an event?

hat is the SetValue action? How is it used?
. Event-Driven Programming Using Macros

ers often turn to the Access macro language to 
plement basic triggers.

e macro language itself consists of 40 or so com-
ands. Although it is essentially a procedural lan-
age (like VBA), the commands are relatively high 

vel and easy to understand. In addition, the macro 
itor simplifies the specification of the action argu-

ents  (parameters).

.1.3 The trigger design cycle
 create a trigger, you need to answer two ques-
ns:

What has to happen?
When should it happen?

nce you have answered the first question (“what”), 
u can create a macro (or VBA procedure) to exe-
te the necessary steps. Once you know the 
swer to the second question (“when”), you can 

attach th
rect obje
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13
In
tri
th
in

he basics of the macro editor
ction, you are going to eliminate the warn-
ages that precede the trigger you created 
1.3.5.

 the answer to the “what” question is the fol-

off the warnings so the dialog boxes do not 
p when the action query is executed;
he action query; and,
the warnings back on (it is generally good 
amming practice to return the environment 
original state).

umber of things have to happen, you can-
n an action query by itself. You can, how-
cute a macro that executes several actions 
 one or more action queries.
. Event-Driven Programming Using Macros

� How do I make the execution of particular 
macro actions conditional?

� What is a switchboard and how do I create 
one for my application?

� How to I make things happen when the 
application is opened?

� What are the advantages and disadvantages 
of event-driven programming?

.3 Tutorial exercises
 this tutorial, you will build a number of very simple 
ggers using Access macros. These triggers, by 
emselves, are not particularly useful and are 
tended for illustrative purposes only.

13.3.1 T
In this se
ing mess
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progr
to its 

Since a n
not rely o
ever, exe
including



Tutorial exercises13

NextHome Previous 5  o f  26

13
Th
cm

al
ne
m

 13.4: Bring up the On Click  property for 
the button.

The button wizard attached a 
VBA procedure to the button.
. Event-Driven Programming Using Macros

• Select the Macros tab from the database window 
and press New. This brings up the macro editor 
shown in Figure 13.2.

• Add the three commands as shown in 
Figure 13.3. Note that the OpenQuery  command 
is used to run the action query.

• Save the macro as mcrUpdateCredits  and 
close it.

.3.2 Attaching the macro to the event
e answer to the “when” question is: When the 
dUpdateCredits  button is pressed. Since you 

ready created the button in Section 11.3.5, all you 
ed to do is modify its On Click property to point the 

crUpdateCredits  macro.
• Open frmDepartments  in design mode.
• Bring up the property sheet for the button and 

scroll down until you find the On Click property, 
as shown in Figure 13.4.

FIGURE
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ditor.

In the comment column, you can 
document your macros as required
. Event-Driven Programming Using Macros

FIGURE 13.2: The macro e

Macro actions can be selected from a list. The 
SetWarnings  command is used to turn the warning 
messages (e.g., before you run an action query) on and off.

Most actions have one or 
more arguments that 
determine the specific 
behavior of the action. In 
this case, the 
SetWarnings  action is 
set to turn warnings off.

The area on the right 
displays information about 
the action.

Multiple commands are 
executed from top to 
bottom.
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the “what” question.

�

�

. Event-Driven Programming Using Macros

FIGURE 13.3: Create a macro that answers 

Add the three commands to 
the macro.

The arguments for the two 
SetWarnings  actions 
are straightforward. For the 
OpenQuery  command, 
you can select the query to 
open (or run) from a list. 
Since this is an action 
query, the second and third 
arguments are not 
applicable.
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•

•

 13.5: Select the macro to attach to the 
On Click  property.

Press the arrow to get a list 
of available macros�
. Event-Driven Programming Using Macros

• Press the builder button ( ) beside the existing 
procedure and look at the VBA subroutine cre-
ated by the button wizard. Most of this code is for 
error handling.

Unlike the stand-along VBA modules you cre-
ated in Tutorial 12, this module (collection of 
functions and subroutines) is embedded in 
the frmDepartments  form.

Since you are going to replace this code with a 
macro, you do not want it taking up space in your 
database file. Highlight the text in the subroutine 
and delete it. When you close the module win-
dow, you will see the reference to the “event pro-
cedure” is gone.
Bring up the list of choice for the On Click prop-
erty as shown in Figure 13.5. Select mcrUp-

dateCredits .

FIGURE
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 modify the structure of the table until the 
ery or form is closed.

e Caption property to Credits updated?  
e Default property to No as shown in 

e 13.6.

 made to a table do not automatically carry 
rms already based on that table. As such, 

t manually add the new field to the depart-
rm.
 frmDepartments  in design mode.
 sure the toolbox and field list are visible. 
e that the new field (CrUpdated ) shows up 
 field list.
he same technique for creating combo 
 to create a bound check box control for the 
o field. This is shown in Figure 13.7.
. Event-Driven Programming Using Macros

• Switch to form view and press the button. Since 
no warnings appear, you may want to press the 
button a few times (you can always use your roll-
back query to reset the credits to their original 
values).

.3.3 Creating a check box to display 
update status information

nce the warning boxes have been disabled for the 
date credits trigger, it may be useful to keep track 

 whether courses in a particular department have 
ready been updated.

 do this, you can add a field to the Departments  
ble to store this “update status” information.
• Edit the Departments  table and add a Yes/No 

field called CrUpdated . 

If you have an open query or form based on 
the Departments  table, you will not be able 

to
qu

• Set th
and th
Figur

Changes
over to fo
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ments fo
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• Make

Notic
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So
m

on, you are going to use one of the most 
mmands—SetValue —to automatically 
he value of the CrUpdated  check box.
 your mcrUpdateCredits  macro in design 
 and add a SetValue  command to change 
rUpdated  check box to Yes (or True , if 
refer). This is shown in Figure 13.8.
 the macro and press the button on the form. 
e that the value of the check box changes, 
ding you not to update the courses for a 
ular department more than once.

Creating conditional macros
an relying on the user not to run the update 
 check box is checked, you may use a con-
acro  to prevent an update when the 

x is checked.
. Event-Driven Programming Using Macros

.3.4 The SetValue  command
 far, you have used two commands in the Access 

acro language: SetWarnings  and OpenQuery . In 

this secti
useful co
change t

• Open
mode
the C
you p

• Save
Notic
remin
partic

13.3.5
Rather th
when the
ditional m
check bo

FIGURE 13.6: Add a field to the Departments  
table to record the status of updates.
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ck of the update status.

Select the check box tool 
from the toolbox.�

the 

A check box is a control 
that can be bound to fields 
of the yes/no data type. 
When the box is checked, 
True  is stored in the 
table; when the box is 
unchecked, False  is 
stored.
. Event-Driven Programming Using Macros

FIGURE 13.7: Add a check box control to keep tra

Drag the CrUpdated  field from 
field list to the detail section.�
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of the update status field when the 

The Expression argument is the 
value you want the SetValue  
action to set the value of the Item 
to. Type in Yes (no quotation 
marks are required since Yes is 
recognized as a constant in this 
context).

�

. Event-Driven Programming Using Macros

FIGURE 13.8: Add a SetValue  command to set the value 
update is compete.

Pick the SetValue  command 
from the list or simply type it in.�

The Item argument is the thing you 
want the SetValue  action to set the 
value of. You can use the builder or 
simply type in CrUpdate .

�
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The simplest conditional macro

 an expression in the condition column of a 
e action in that row will execute if the condi-
e. If the condition is not true, the action will 
d.

 the condition column as shown in 
e 13.10. Precede the actions you want to 
te if the check box is checked with [CrUp-

] . Precede the actions you do not want to 
te with Not [CrUpdated] .

nce CrUpdated  is a Boolean  (yes/no) vari-
le, you do not need to write [CrUpdated] 

True  or [CrUpdated] = False . The 
e and false parts are implied. However, if a 
n-Boolean data type is used in the expres-
n, a comparison operator must be included 

.g., [DeptCode] = “COMM” , [Cred-

] < 3 , etc.)
. Event-Driven Programming Using Macros

• Select View > Conditions to display the condi-
tions column in the macro editor as shown in 
Figure 13.9.

13.3.5.1

If there is
macro, th
tion is tru
be skippe

• Fill in
Figur
execu
dated

execu

Si
ab
= 

tru
no
sio
(e
its

FIGURE 13.9: Display the macro editors 
condition column

Select View > Conditions or press the 
“conditions” button on the tool bar.�
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ol which actions execute.
. Event-Driven Programming Using Macros

FIGURE 13.10: Create a conditional macro to contr

The expression Not [CrUpdated]  
is true if the CrUpdated  check box is 
not checked. Use this expression in 
front of the actions you want to execute 
in this situation.

�

The expression [CrUpdated]  is 
true if the CrUpdated  check box is 
checked. In this situation, you should 
indicate to the user that the update is 
not being performed.

�

The MsgBox action displays a 
standard Windows message box. You 
can set the message and other message 
box features in the arguments section.

�
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Refining the conditions

ro shown in Figure 13.10 can be improved 
an ellipsis (…) instead of repeating the 
ndition in line after line. In this section, you 
lify your conditional macro slightly.

 message box action and condition to the 
 list of actions by dragging its record selec-
box on the left).
 a new row immediately following the mes-
and add a StopMacro  action, as shown in 
e 13.12.

ro in Figure 13.12 executes as follows: If 
 is true (i.e., the box is checked), the 

action executes. Since the next line has an 
 the condition column, the condition contin-
ply. However, that action on the ellipsis line 
acro , and thus the macro ends without 
 the next four lines.

F

. Event-Driven Programming Using Macros

• Switch to the form and test the macro by pressing 
the button. If the CrUpdated  check box is 
checked, you should get a message similar to 
that shown in Figure 13.11.

13.3.5.2

The mac
by using 
same co
will simp

Move the
top of the
tor (grey 

• Insert
sage 
Figur

The mac
CrUpdate

MsgBox 
ellipsis in
ues to ap
is StopM

executing

IGURE 13.11: The action query is not executed 
and the message box appears instead.
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pdate  box is not checked, the first two 
 ignored (i.e., the lines with the false condi-
the ellipsis) and the update proceeds.

Creating a group of named macros

ible to store a number of related macros 
in one macro “module”. These group mac-
 two advantages:

lar macros can be created  — instead of 
g a large macro with many conditions and 
hes, you can create a small macro that call 
 small macros.
r macros can be grouped together  — for 
ple, you could keep all you Departments -
d macros or search-related macros in a 
 group.

ction, we will focus on the first advantage.
t View > Macro Names to display the macro 
 column.

FI
. Event-Driven Programming Using Macros

If the CrU

lines are
tion and 

13.3.5.3

It is poss
together 
ros  have

1. Modu
havin
branc
other

2. Simila
exam
relate
macro

In this se
• Selec

name

GURE 13.12: Rearrange the macro actions and 
insert a new row.

Click the record selector and drag the 
message box action to the top of the list.�

Right-click where you would like 
to insert a new row and select 
Insert Row from the popup menu.

�

Add an ellipsis 
(…) and a 
StopMacro  
action.

�
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•

ve the scroll bars, navigation buttons, and 
d selectors from the form using the form’s 
rty sheet.
 the form as swbMain .

 two ways to add button-based triggers to a 

the button wizard off, create the button, and 
 an macro containing the appropriate 
 (or actions).

the button wizard on and use the wizard to 
t from a list of common actions (the wizard 
 a VBA procedure for you).

nce the wizard can only attach one action to 
button (such as opening a form or running 
 action query) it is less flexible than a 

acro. However, once you are more comfort-
le with VBA, there is nothing to stop you 
. Event-Driven Programming Using Macros

• Perform the steps in Figure 13.13 to modularize 
your macro.

• Change the macro referred to in the On Click 
property of the cmdUpdateCredits  button from 
mcrUpdateCredits  to
mcrUpdateCredits.CheckStatus .

• Test the operation of the button.

.3.6 Creating switchboards
ne of the simplest (but most useful) triggers is an 
penForm command attached to a button on a form 
nsisting exclusively of buttons.

is type of “switchboard” (as shown in 
gure 13.14) can provide the user with a means of 
vigating the application.
Create an unbound form as shown in 
Figure 13.15.

• Remo
recor
prope

• Save

There are
form:

1. Turn 
attach
action

2. Turn 
selec
writes

Si
a 
an
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ularize the macro.

 macro executes until it encounters a 
lank line. Use blank lines to separate the 
amed macros within a group.
. Event-Driven Programming Using Macros

FIGURE 13.13: Use named macros to mod

Select View > Macro Names to display 
the macro names column.�

Create a named macro called 
CheckStatus  that contains the 
conditional logic for the procedure.

�

The RunMacro  action executes a 
particular macro. Select the macro to 
execute from a list in the arguments pane. 
Note the naming convention for macros 
within a macro group.

�

Create two other macros, Updated  and 
NotUpdated  that correspond to the 
logic in the CheckStatus  macro.

�

A
b
n
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 the application.

tcut keys are include on each 
n to allow the user to navigate 
pplication with keystrokes.

gh it is not shown here, switchboards can 
er switchboards, allowing you to add a 
hical structure to your application.
. Event-Driven Programming Using Macros

FIGURE 13.14: A switchboard interface to

The command buttons are placed on an 
unbound form. Note the absence of scroll bars, 
record selectors, or navigation buttons.

Gratuitous clip art can be used to 
clutter your forms and reduce the 
application’s overall performance.

Shor
butto
the a

Althou
call oth
hierarc
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E 13.15: Create an unbound form as the 
switchboard background.

Select Design View (no wizard) and 
leave the “record source” box empty.�

The result is a blank form on which 
you can build your switchboard.�
. Event-Driven Programming Using Macros

FIGUR
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•

13

 the directions provided by the wizard to 
e action for the button (i.e., open the frm-

es  form) as shown in Figure 13.17.
ge the button’s font and resize it as 
ed.

u can standardize the size of your form 
jects by selecting more than one and using 
rmat > Size > to Tallest and to Widest com-

ands. Similarly, you can select more than 
e object and use the “multiple selection” 
operty sheet to set the properties all at 
ce.

Using an autoexec  macro
e the name autoexec  to save a macro (in 
e normal mcr<name> convention), Access 
ute the macro actions when the database is 
Consequently, auto-execute macros are 
. Event-Driven Programming Using Macros

from editing the VBA modules created by the 
wizard to add additional functionality.

.3.6.1 Using a macro and manually-created 
buttons

• Ensure the wizard is turned off and use the but-
ton tool to create a button.

• Modify the properties of the button as shown in 
Figure 13.16.

• Create a macro called
mcrSwitchboard.OpenDept  and use the 
OpenForm command to open the form frmDe-

partments .
Attach the macro to the On Click event of the 
cmdDepartments  button.

• Test the button.

.3.6.2 Using the button wizard
• Turn the button wizard back on and create a new 

button.

• Follow
set th
Cours

• Chan
requir

Yo
ob
Fo
m
on
pr
on

13.3.7
If you us
lieu of th
will exec
opened. 
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fy its appearance.

Give the button a meaningful name 
(e.g., cmdDepartments ) and caption 
(including a shortcut key.).

�

e 
 
.

. Event-Driven Programming Using Macros

FIGURE 13.16: Create a button and modi

Use the button tool to create a button 
(ensure the wizard activated).�

Scroll down the property sheet and chang
the value of the button’s Font Size property.
Resize the button by dragging its handles

�
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e a button for the switchboard.

rm as 
 button.

ect form 

Provide a caption 
for the button.�
. Event-Driven Programming Using Macros

FIGURE 13.17: Use the command button wizard to creat

Select Form Operations > Open Fo
the action type associated with the�

Select the corr
from the list.�
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menu system. Consequently, you need to 
ething about the menu structure of Access 

u create your macro.

 version 8.0, the DoMenuItem  action has 
en replaced by the slightly more intuitive 
nCommand action. See on-line help for 

ore information on RunCommand.

e an auto-execute macro
he DoMenuItem  and OpenForm actions to 
he database window and open the main 
board, as shown in Figure 13.18.
 the database and reopen it after a short 
 to test the macro.

 version 7.0 and above, you do not need to 
e an autoexec macro to hide the database 
ndow and open a form. Instead, you can 
ht-click on the database window, select 
. Event-Driven Programming Using Macros

ten used to display a switchboard when the user 
arts the application.

other typical auto-execute operation is to hide the 
tabase window. By doing this, you unclutter the 
reen and reduce the risk of a user accidentally 
aking a change to the application (by deleting a 
tabase object, etc.).

To unhide the database window, select Win-
dow > Unhide from the main menu or press 
the database window icon ( ) on the toolbar.

e problem with hiding the database window using 
macro is that there is no HideDatabaseWindow  
mmand in the Access macro language. As such, 
u have to rely on the rather convoluted DoMenu-

m  action.

 its name suggests, the DoMenuItem  action per-
rms an operation just as if it had been selected 

from the 
know som
before yo

In
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• Creat
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• Close
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iscussion

vent-driven programming versus 
conventional programming
ary advantages of event-driven program-
 the following:

ility  — since the flow of the application is 
lled by events rather than a sequential pro-

, the user does not have to conform to the 
ammer’s understanding of how tasks should 
ecuted.
stness  — Event-driven applications tend to 
re robust since they are less sensitive to 
der in which users perform activities. In 
ntional programming, the programmer has 
icipate virtually every sequence of activities 
er might perform and define responses to 

 sequences.
. Event-Driven Programming Using Macros

Startup, and fill in the properties for the appli-
cation.

13.4 D

13.4.1 E

The prim
ming are

1. Flexib
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gram
progr
be ex

2. Robu
be mo
the or
conve
to ant
the us
these

FIGURE 13.18: Create an auto-execute macro.

For the DoMenuItem  action, select the 
Window > Hide commands from the 
Database menu (i.e., the menu that is active 
when the database window is being used).

�
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e a main switchboard for you application. It 
d provide links to all the database objects 
ser is expected to have access to (i.e., your 
).
. Event-Driven Programming Using Macros

e primary disadvantage of event-driven programs 
that it is often difficult to find the source of errors 
en they do occur. This problem arises from the 
ject-oriented nature of event-driven applications—
ce events are associated with a particular object 
u may have to examine a large number of objects 
fore you discover the misbehaving procedure. 
is is especially true when events cascade (i.e., an 
ent for one object triggers an event for a different 
ject, and so on).

.5 Application to the assignment
• Add “update status” check boxes to you transac-

tion processing forms (i.e., Orders  and Ship-

ments )
• Create a conditional macro for your Shipments  

form to prevent a particular shipment from being 
added to inventory more than once.

• Creat
shoul
your u
forms
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